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Purpose 
This guide covers how to determine whether a PDF is accessible, what the key elements of an accessible 

PDF are, and how to fix common accessibility problems using Adobe Acrobat Pro, which is available to all 

Ball State employees. 

The Fastest Path to an Accessible PDF 

The most efficient way to produce an accessible PDF is to create an accessible source document 
first (in Word, PowerPoint, or InDesign), then export it to PDF correctly. Remediating a badly 
structured PDF in Acrobat is significantly more work than getting it right at the source. If you have 
access to the source file, fix it there first. 

Section 1: How to Determine If a PDF Is Accessible 
Before you start fixing anything, you need to know whether the PDF has accessibility problems and what 

they are. There are two methods: a quick manual check and the built-in Accessibility Checker in Acrobat. 

Quick Manual Check (30 seconds) 

These four tests will tell you immediately whether a PDF has fundamental accessibility problems: 

1. Can you select the text? Open the PDF and try to click and drag to highlight text. If you cannot 

select any text, the PDF is likely a scanned image—a photograph of a page rather than actual 

digital text. Screen readers cannot read image-based PDFs at all. This is the most severe 

accessibility failure a PDF can have. 

2. Does it have tags? In Acrobat, go to File → Properties (or Ctrl+D / Cmd+D). In the Description 
tab, look at the bottom for “Tagged PDF.” If it says “No,” the PDF has no structural tags and is not 

accessible. Tags are what tell screen readers which content is a heading, which is a paragraph, 

which is a list, and in what order to read the page. 

3. Does it have a title? In the same Document Properties dialog, check the Description tab. The 

Title field should contain a meaningful document title—not a filename. If it’s blank or says 

something like “Microsoft Word - budget_v3_final.docx,” it needs to be fixed. 

4. Do images have alt text? If the PDF contains images, charts, or graphics, check whether they 

have alternative text. You can do this by hovering over an image with the cursor—if a tooltip 

appears with descriptive text, alt text exists. If no tooltip appears, it likely doesn’t. (The 
Accessibility Checker will also flag this.) 

If the PDF fails any of these four checks, it needs remediation. If it passes all four, run the full Accessibility 

Checker to catch subtler issues. 



PDF Evaluation and Accessibility Remediation Guide 

Ball State University | Effective April 24, 2026 | ADA Title II Web Accessibility Rule Compliance 

Running the Accessibility Checker 

Acrobat Pro has a built-in tool that checks for most accessibility requirements automatically. Here is how 

to run it: 

5. Open the PDF in Adobe Acrobat Pro. 

6. Select All Tools in the top-left. 

7. Select Prepare for Accessibility. 

8. Select Check for Accessibility. 

9. In the dialog that opens, leave all checking options selected for a complete report. Select Start 

Checking. 

10. The results appear in the Accessibility Checker panel on the right side of the document. 

Understanding the Results 

The checker organizes results into seven categories. Each item gets one of four statuses: 

Status What It Means 

Passed The item meets accessibility requirements. No action needed. 

Failed The item does not meet requirements. Right-click the item for options: Fix 
(Acrobat attempts an automatic fix or prompts you), Explain (opens help 
documentation), or Show in Tags Panel (navigates to the problem). 

Needs Manual 
Check 

Acrobat cannot verify this automatically. You must inspect it yourself. Common 
examples: reading order, color contrast, and whether alt text is actually 
meaningful (not just present). 

Skipped The rule was not checked. This usually means the option was deselected before 
running the check. 

The seven categories the checker evaluates are: Document (title, language, tagging, bookmarks, tab 

order), Page Content (tagged content, tagged annotations), Forms (tagged form fields, field descriptions), 

Alternative Text (figures, other elements needing alt text), Tables (proper row/column structure, header 

cells), Lists (proper list item nesting), and Headings (proper heading structure and nesting). 
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Section 2: The Key Elements of an Accessible PDF 
An accessible PDF must have all of the following. If any element is missing, the PDF does not meet 

WCAG 2.1 Level AA. 

Element Why It Matters WCAG Criteria 

Searchable text (not a 
scanned image) 

Screen readers read text. They cannot read 
images of text. A scanned PDF is invisible 
to assistive technology. 

1.1.1, 1.4.5 

Tags (document 
structure) 

Tags define what each element is: heading, 
paragraph, list, table, image. Without tags, a 
screen reader reads the PDF as a single 
undifferentiated stream of text with no 
structure. 

1.3.1, 1.3.2 

Correct reading order Tags must be in the order a person would 
logically read the content. Multi-column 
layouts, sidebars, and headers/footers often 
cause reading order problems. 

1.3.2 

Document title The PDF must have a meaningful title in 
Document Properties, and must be set to 
display the title (not the filename) in the title 
bar. 

2.4.2 

Document language The primary language must be specified so 
screen readers pronounce words correctly. 

3.1.1 

Alternative text on 
images 

Every image that conveys information must 
have alt text. Decorative images must be 
marked as artifacts so screen readers skip 
them. 

1.1.1 

Heading structure Headings must be properly tagged (H1, H2, 
H3, etc.) and must not skip levels. Screen 
reader users navigate documents by 
jumping between headings. 

1.3.1, 2.4.6 

Table structure Tables must have header cells (TH) 
identified separately from data cells (TD) so 
screen readers can associate data with its 
column or row header. 

1.3.1 

List structure Lists must be tagged as lists (L) with list 
items (LI), not as plain paragraphs with 
bullet characters. 

1.3.1 

Bookmarks (21+ 
pages) 

Documents with 21 or more pages must 
include bookmarks that mirror the heading 
structure, allowing users to navigate the 
document. 

2.4.5 

Color contrast Text must have a 4.5:1 contrast ratio 
against its background (3:1 for large text). 

1.4.3 
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The Accessibility Checker flags this for 
manual review. 

Tab order matches 
reading order 

For PDFs with links or form fields, the tab 
order must follow the document structure so 
keyboard users move through the document 
logically. 

2.1.1, 2.4.3 

Section 3: Fixing Common Accessibility Issues in 
Adobe Acrobat Pro 

Before You Begin 

Save a copy of the original PDF before making any changes. Acrobat’s undo/redo does not work 
reliably for all accessibility edits. Work on a copy so you can start over if needed. Save frequently 
throughout the remediation process. 

3.1 Fixing Scanned/Image-Based PDFs (OCR) 

If the PDF is a scanned image (you cannot select text), you must run Optical Character Recognition 

(OCR) to convert the image into searchable text before you can do anything else. 

11. Open the PDF in Acrobat Pro. 

12. Select All Tools → Scan & OCR. 

13. Select Recognize Text → In This File. 

14. Set the language to English (or the appropriate language) and select Recognize Text. 

15. After OCR completes, try selecting text to confirm it worked. Then proceed with the remaining 

remediation steps below. 

OCR Limitation 

OCR is not perfect. It works best on clean, high-resolution scans with standard fonts. Handwritten 
text, poor-quality scans, and unusual fonts may produce errors. After running OCR, review the text 
for accuracy. If the scan quality is too poor for reliable OCR, consider recreating the document from 
scratch—the time spent correcting OCR errors may exceed the time to rebuild it. 

3.2 Adding Tags to an Untagged PDF 

If the PDF has no tags (Document Properties shows “Tagged PDF: No”), you need to add them. There 
are two approaches: 

Automatic Tagging (start here) 

16. Select All Tools → Prepare for Accessibility → Automatically Tag PDF. 

17. Acrobat will analyze the document and assign tags based on its best interpretation of the content 

structure. 
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18. Review the tags it created. Automatic tagging gets the basics right for simple documents but 

frequently misidentifies elements in complex layouts. You will almost always need to make 

manual corrections. 

Manual Tagging with the Fix Reading Order Tool 

This is the primary tool for reviewing and correcting tags. Use it after automatic tagging to fix what 

Acrobat got wrong, or to tag a document from scratch. 

19. Select All Tools → Prepare for Accessibility → Fix Reading Order. 

20. In the Reading Order dialog that opens, make sure Show page content groups is selected, and 

choose Structure types to see the current tags overlaid on the page. 

21. Each content region on the page is highlighted with a number showing its reading order position 

and a label showing its current tag type (P for paragraph, H1 for heading 1, Figure, Table, etc.). 

22. To change a tag: draw a selection rectangle around the content, then click the appropriate button 

in the dialog box (Heading 1, Heading 2, Heading 3, Text/Paragraph, Figure, Table, etc.). 

23. To mark decorative content that screen readers should skip (ornamental borders, background 

images, page decorations): select the content and click Background/Artifact. 

3.3 Fixing Reading Order 

Reading order problems are common in PDFs with multi-column layouts, sidebars, headers, footers, and 

pull quotes. A screen reader reads content in tag order—if the tags are in the wrong order, the content 

makes no sense. 

24. With the Fix Reading Order tool open, select Show Order Panel in the dialog box. 

25. The Order panel shows all tagged content in the sequence a screen reader will read it. 

26. Click each item in the Order panel. As you click, the corresponding content highlights on the 

page. This lets you see whether the order is logical. 

27. To reorder: drag and drop items in the Order panel to the correct position. 

28. Common problems to watch for: content reading across columns instead of down them, headers 

or footers reading in the middle of body text, sidebars interrupting the main text flow, and captions 

separated from their images. 

3.4 Setting Document Title and Language 

Title 

29. Select File → Properties (or Ctrl+D / Cmd+D). 

30. In the Description tab, enter a meaningful title in the Title field (e.g., “2026 Spring Course 
Catalog”—not “catalog_final_v3.pdf”). 

31. Switch to the Initial View tab. Under the Show drop-down, select Document Title. This ensures 

the title bar displays the title, not the filename. 

32. Select OK. 
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Language 

33. In the same Document Properties dialog, select the Advanced tab. 

34. In the Reading Options section, set the Language drop-down to English (or the appropriate 

language). 

35. Select OK. 

3.5 Adding Alternative Text to Images 

Every image that conveys meaningful information needs alt text. Decorative images should be marked as 

artifacts. 

Method 1: Using the Add Alternate Text Tool 

36. Select All Tools → Prepare for Accessibility → Add Alternate Text. 

37. Acrobat will detect all figures in the document and display them one at a time. 

38. For each figure, enter a concise, meaningful description in the text field, or check Decorative 

figure if the image is purely ornamental. 

39. Select Save & Close when finished. 

Method 2: Using the Tags Panel 

40. Open the Accessibility Tags panel: View → Show/Hide → Side Panels → Accessibility Tags. 

41. Navigate the tag tree to find the <Figure> tag for the image. 

42. Right-click the Figure tag and select Properties. 

43. In the Object Properties dialog, enter the description in the Alternate Text field. 

44. Select Close. 

What to write: Follow the same principles as web alt text. Describe the content and function of the 

image. Don’t start with “image of.” Be specific: “Bar chart showing enrollment growth from 18,000 
students in 2020 to 22,000 in 2025” is useful; “chart” is not. 

3.6 Fixing Heading Structure 

Headings must be tagged with the correct level (H1, H2, H3, etc.) and must not skip levels (e.g., jumping 

from H1 to H3). Screen reader users rely on headings to navigate and understand document structure. 

45. Use the Fix Reading Order tool to select heading text and assign the correct heading level 

(Heading 1, Heading 2, or Heading 3 buttons in the dialog). 

46. For heading levels beyond H3, use the Accessibility Tags panel: right-click the tag, select 

Properties, and change the Type drop-down to the correct heading level (H4, H5, H6). 

47. Verify the hierarchy is logical: the document should have one H1 (the document title), with H2s for 

major sections, H3s for subsections, and so on. Do not skip levels. 
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3.7 Fixing Table Structure 

Tables are one of the most complex elements to remediate. Screen readers need to know which cells are 

headers and which are data so they can announce “Column: Budget, Row: Marketing, Value: $45,000” 
rather than just “$45,000.” 

48. In the Fix Reading Order tool, select the table content and click the Table button to tag it as a 

table. 

49. Click Table Editor in the Reading Order dialog to inspect the table’s cell structure. 

50. Each cell will be labeled as either TD (table data) or TH (table header). Header cells in the first 

row or column should be TH, not TD. 

51. To change a cell: right-click the cell tag and select Table Cell Properties. Change the Type to 

Header Cell and set the Scope to Column or Row as appropriate. Select OK. 

52. Repeat for all header cells in the table. 

Complex Tables 

Tables with merged cells, nested headers, or irregular layouts are extremely difficult to remediate in 
Acrobat. If you encounter a complex table, it is almost always faster to rebuild it in the source 
application (Word, Excel) with proper header rows and export a new PDF than to fix the tag structure 
in Acrobat. 

3.8 Fixing List Structure 

Bulleted and numbered lists must be tagged as List (L) elements containing List Item (LI) children—not as 

plain paragraphs that happen to start with a bullet character. The Fix Reading Order tool does not have a 

List button, so list structure must be fixed in the Accessibility Tags panel. 

53. Open the Accessibility Tags panel (View → Show/Hide → Side Panels → Accessibility Tags). 

54. Find the content that should be a list. If it’s currently tagged as paragraphs (P), right-click the first 

paragraph tag and select Properties. Change the Type to List Item (LI). 

55. Create a parent List (L) tag: right-click the parent element, select New Tag, and set the type to L. 

Drag the LI tags into the L tag. 

56. Each LI should contain an Lbl (label—the bullet or number) and an LBody (the list item text). If 

these sub-elements are missing, the Accessibility Checker may still pass, but a fully compliant 

structure includes them. 

3.9 Adding Bookmarks 

Documents with 21 or more pages must include bookmarks. Bookmarks allow users to navigate the 

document by jumping to sections—similar to a clickable table of contents. 

57. If the Accessibility Checker flags missing bookmarks: right-click Bookmarks in the checker 

results and select Fix. 

58. In the Structure Elements dialog that appears, select the heading elements you want to convert to 

bookmarks. Typically, select all H1 and H2 elements. 

59. Select OK. Acrobat creates bookmarks linked to those heading locations in the document. 
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3.10 Fixing Tab Order 

For PDFs with links or form fields, the tab order must follow the document structure so keyboard users 

navigate in a logical sequence. 

60. If the Accessibility Checker flags tab order: right-click Tab Order in the checker results and select 

Fix. Acrobat will set the tab order to match the document structure automatically. 

61. To set manually: open the Page Thumbnails panel, right-click a page thumbnail, select Page 

Properties, choose Tab Order, and select Use Document Structure. Repeat for each page. 

Section 4: Special Understandings 

PDF Forms 

If the PDF contains form fields (text inputs, checkboxes, dropdowns), each field must have a descriptive 

label that a screen reader can announce. In the Fix Reading Order dialog, select any form element and 

click Form Field to tag it. Then, in Acrobat’s form editing mode (All Tools → Prepare a Form), select each 
field, open its properties, and enter a descriptive label in the Tooltip field. 

Links 

Links within a PDF must have meaningful text. A link that just shows a bare URL is not helpful to a screen 

reader user. To add meaningful alternate text to a link, find the link’s tag in the Accessibility Tags panel, 

right-click it, select Properties, and enter descriptive text in the Alternate Text field (e.g., “Ball State 
admissions application page”). 

Flyers, Posters, and Graphic-Heavy PDFs 

PDFs that are essentially full-page graphics (flyers designed in Canva, event posters, infographics) are 

among the hardest to remediate because the entire content may be a single image. For these: 

• If the entire PDF is one image: the alt text for that image must contain all the information the 

image conveys. This can mean a very long alt text description. 

• A better approach: recreate the content as a tagged, text-based PDF or as an accessible web 

page, and post that instead of (or alongside) the graphic PDF. 

• If you must post a graphic PDF, consider also providing an accessible HTML version on the web 

page where the PDF is linked, containing the same information in text form. 

PDFs versus web content 

• When possible, for the purposes of web content, content should be published as 

accessible HTML web pages rather than PDFs. PDFs should not be used for content that 

is frequently updated, critical for access (e.g., instructions, policies, forms), or intended 

for broad public use unless there is a clear business need. 

NOTE: To discuss this issue more or have additional questions and/or concerns addressed, please 
contact the Marketing and Communications Digital Team. 
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Section 5: Pre-Publish Checklist 
Complete this checklist before posting any PDF to bsu.edu. 

✓ Check 

□ The PDF contains real, selectable text (not a scanned image). If scanned, OCR has been run 
and the text reviewed for accuracy. 

□ The PDF is tagged (Document Properties → Description → Tagged PDF: Yes). 

□ A meaningful document title is set in Document Properties, and Initial View is set to display the 
document title (not the filename). 

□ The document language is set (Document Properties → Advanced → Language). 

□ Every informational image has meaningful alt text. Decorative images are marked as artifacts. 

□ Headings are properly tagged (H1, H2, H3) and do not skip levels. 

□ Reading order is logical (verified using the Fix Reading Order tool’s Order panel). 

□ Tables have header cells (TH) properly identified with correct scope (row or column). 

□ Lists are tagged as List (L) elements with List Item (LI) children—not as plain paragraphs. 

□ If the document is 21+ pages, bookmarks are present and mirror the heading structure. 

□ Tab order is set to Use Document Structure for all pages. 

□ Text meets minimum color contrast requirements (4.5:1 for normal text, 3:1 for large text). 

□ If the PDF contains form fields, every field has a descriptive label/tooltip. 

□ The Accessibility Checker has been run with all options selected and all issues are resolved or 
addressed. 

□ Link text is meaningful (not bare URLs or “click here”). 

Section 6: Compliance Authority 
This guide is issued under the requirements of the ADA Title II final rule (28 CFR Part 35, Subpart H), 

published April 24, 2024, which adopts WCAG 2.1 Level AA as the technical standard for public university 

web content, including PDF documents posted on university websites and mobile apps. Ball State 

University’s compliance deadline is April 24, 2026. 

Under the rule’s preexisting conventional electronic documents exception, PDFs posted before the 
compliance deadline generally do not have to meet WCAG 2.1—unless they are currently used to apply 

for, gain access to, or participate in the university’s services, programs, or activities. Applications, 

enrollment forms, course materials, current handbooks, and similar documents must comply regardless of 

when they were posted. 
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Non-compliance after the deadline exposes the university to enforcement action by the U.S. Department 

of Justice and potential complaints through the ADA complaint process. 

Questions about this guide or its requirements should be directed to Greg Fallon, Associate Vice 

President of University Communications and Digital Strategy, in Marketing and Communications, 

gmfallon@bsu.edu, 765-285-0048. 

mailto:gmfallon@bsu.edu
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