If your map did not load correctly, you may not have the Java Runtime Environment (JRE) installed, please follow the link below to install JRE. Follow the instructions to install  J2SE v 1.4.2_07  JRE and not any of the other downloads. 

If your map loads correctly but you are unable to view the Map data, please make sure to allow pop ups by changing this setting from the Tools Menu.

 

Click here to return to the IBB Home Page.